suchen und nicht finden

Ein regelmäßiger Copy-Job einer Reihe von Dateien und Ordnern auf einem w2003Server wird benötigt. Das hat nichts mit Faulheit zu tun, als vielmehr … ok eigentlich doch mit Faulheit. Admins wollen alles machbare möglichst automatisieren, dafür ist das Zeugs schliesslich auch da.

Die Struktur und Funktion der Batch-Datei wird zuerst lokal an Dummy-Dateien und -Ordnern getestet, so live auf einem Server zu spielen ist mir zu heikel. Als alles zu meiner Zufriedenheit funktioniert, bewegen ich die Batch und eine exclude-Datei (ich brauch nicht jeden Ordner) auf dem Server und passe ich die notwendigen Pfade sehr gewissenhaft an. Ich kontrollieren die Pfade insgesamt 3 Mal bevor ich einen Testlauf starte. Es funktioniert alles wie es soll. Dann fällt mir auch, dass ich die Batch im falschen Verzeichnis liegen habe und bewege sie in das eigentlich richtige. Danach passe ich Pfade in der Batch auf die geänderten Verhältnisse an, ein Testlauf schlägt fehl – kein Error, kein Eintrag in die Ereignisliste, nüscht. Ich prüfe die Pfade, die Berechtigungen, Dateigröße und Integrität (hash md5), alles ohne Befund.

Nach einem Not-Espresso prüfe ich noch einmal alles, weil man sich ab einem Punkt irgendwann selbst misstraut. Wieder ist alles richtig. Ich bewege die Batch wieder zurück zum ersten ‘falschen’ Ordner, passe die Pfade wieder an, Testlauf erfolgreich. Die Batch kommt wieder ins richtige Verzeichnis und ich bitte einen Kollegen die Pfade anzupassen, Berechtigungen zu prüfen, etc, dessen Testlauf schlägt wieder fehl.

Um nicht noch mehr Zeit zu verschwenden lasse ich die Batch nun entnervt dort wo sie ist und dokumentiere dies im AdminsLog. Ich darf Schokolade. Und wieder wurde dank mangelhafter Serversoftware wertvolle Lebenszeit sinnlos verschwendet. 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.